summaryrefslogtreecommitdiff
path: root/apt-pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-23 13:38:19 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-26 15:49:14 +0200
commit374ab017c262108c0f12bcdc8d15ff242c7adc56 (patch)
tree42949b17c7f4607247d9e8a9fd0b3efaebb6d77c /apt-pkg/CMakeLists.txt
parentb10ec8cc7b6b9d181cccacee6b4c1c4c5bdbd510 (diff)
CMake: Do not hardcode -ldl
Does not exist on FreeBSD Gbp-Dch: ignore
Diffstat (limited to 'apt-pkg/CMakeLists.txt')
-rw-r--r--apt-pkg/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/apt-pkg/CMakeLists.txt b/apt-pkg/CMakeLists.txt
index a90bb1d8c..9bbc6bd98 100644
--- a/apt-pkg/CMakeLists.txt
+++ b/apt-pkg/CMakeLists.txt
@@ -30,7 +30,7 @@ target_include_directories(apt-pkg
${LZMA_INCLUDE_DIRS}
${LZ4_INCLUDE_DIRS})
target_link_libraries(apt-pkg
- PRIVATE -lutil -ldl -lresolv
+ PRIVATE -lutil ${CMAKE_DL_LIBS} -lresolv
${CMAKE_THREAD_LIBS_INIT}
${ZLIB_LIBRARIES}
${BZIP2_LIBRARIES}