summaryrefslogtreecommitdiff
path: root/apt-private/CMakeLists.txt
diff options
context:
space:
mode:
authorCoolStar <coolstarorganization@gmail.com>2019-05-02 01:02:42 -0700
committerSam Bingner <sam@bingner.com>2019-12-26 15:24:16 -1000
commitd784ec66fa0019ae1b359578a85488649fdbd621 (patch)
treec6f902c34d81b7326084fff2aac4ec31889a8362 /apt-private/CMakeLists.txt
parent713b65be84830af1a57148b44dc1d1d4010ece3e (diff)
1.8.0-Sileosille-apt
Diffstat (limited to 'apt-private/CMakeLists.txt')
-rw-r--r--apt-private/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/apt-private/CMakeLists.txt b/apt-private/CMakeLists.txt
index 88a8f97fe..4a6ea51b8 100644
--- a/apt-private/CMakeLists.txt
+++ b/apt-private/CMakeLists.txt
@@ -5,14 +5,14 @@ set(MINOR 0)
# Definition of the C++ files used to build the library - note that this
# is expanded at CMake time, so you have to rerun cmake if you add or remove
# a file (you can just run cmake . in the build directory)
-file(GLOB_RECURSE library "*.cc")
+file(GLOB_RECURSE library "*.cc" "*.mm")
file(GLOB_RECURSE headers "*.h")
# Create a library using the C++ files
add_library(apt-private SHARED ${library})
# Link the library and set the SONAME
-target_link_libraries(apt-private PUBLIC apt-pkg)
+target_link_libraries(apt-private PUBLIC apt-pkg "-framework Foundation")
set_target_properties(apt-private PROPERTIES VERSION ${MAJOR}.${MINOR})
set_target_properties(apt-private PROPERTIES SOVERSION ${MAJOR})
set_target_properties(apt-private PROPERTIES CXX_VISIBILITY_PRESET hidden)