summaryrefslogtreecommitdiff
path: root/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorCoolStar <coolstarorganization@gmail.com>2019-05-02 01:02:42 -0700
committerSam Bingner <sam@bingner.com>2019-12-26 15:24:16 -1000
commitd784ec66fa0019ae1b359578a85488649fdbd621 (patch)
treec6f902c34d81b7326084fff2aac4ec31889a8362 /methods/CMakeLists.txt
parent713b65be84830af1a57148b44dc1d1d4010ece3e (diff)
1.8.0-Sileosille-apt
Diffstat (limited to 'methods/CMakeLists.txt')
-rw-r--r--methods/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/methods/CMakeLists.txt b/methods/CMakeLists.txt
index c4a32b4f5..14689bbfe 100644
--- a/methods/CMakeLists.txt
+++ b/methods/CMakeLists.txt
@@ -2,32 +2,34 @@
include_directories($<$<BOOL:${SECCOMP_FOUND}>:${SECCOMP_INCLUDE_DIR}>)
link_libraries(apt-pkg $<$<BOOL:${SECCOMP_FOUND}>:${SECCOMP_LIBRARIES}>)
-add_library(connectlib OBJECT connect.cc rfc2553emu.cc)
+#add_library(connectlib OBJECT connect.cc rfc2553emu.cc)
add_executable(file file.cc)
add_executable(copy copy.cc)
add_executable(store store.cc)
add_executable(gpgv gpgv.cc)
add_executable(cdrom cdrom.cc)
-add_executable(http http.cc basehttp.cc $<TARGET_OBJECTS:connectlib>)
+#add_executable(http http.cc basehttp.cc $<TARGET_OBJECTS:connectlib>)
+add_executable(https nshttp.mm)
add_executable(mirror mirror.cc)
-add_executable(ftp ftp.cc $<TARGET_OBJECTS:connectlib>)
+#add_executable(ftp ftp.cc $<TARGET_OBJECTS:connectlib>)
add_executable(rred rred.cc)
add_executable(rsh rsh.cc)
-target_compile_definitions(connectlib PRIVATE ${GNUTLS_DEFINITIONS})
-target_include_directories(connectlib PRIVATE ${GNUTLS_INCLUDE_DIR})
+#target_compile_definitions(connectlib PRIVATE ${GNUTLS_DEFINITIONS})
+#target_include_directories(connectlib PRIVATE ${GNUTLS_INCLUDE_DIR})
# Additional libraries to link against for networked stuff
-target_link_libraries(http ${GNUTLS_LIBRARIES})
-target_link_libraries(ftp ${GNUTLS_LIBRARIES})
+#target_link_libraries(http ${GNUTLS_LIBRARIES})
+target_link_libraries(https "-framework Foundation")
+#target_link_libraries(ftp ${GNUTLS_LIBRARIES})
# Install the library
-install(TARGETS file copy store gpgv cdrom http ftp rred rsh mirror
+install(TARGETS file copy store https gpgv cdrom rred rsh mirror
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/apt/methods)
add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods mirror mirror+ftp mirror+http mirror+https mirror+file mirror+copy)
add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods rsh ssh)
-add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods http https)
+#add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods http https)