summaryrefslogtreecommitdiff
path: root/apt-private/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apt-private/CMakeLists.txt')
-rw-r--r--apt-private/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/apt-private/CMakeLists.txt b/apt-private/CMakeLists.txt
index 88a8f97fe..4a6ea51b8 100644
--- a/apt-private/CMakeLists.txt
+++ b/apt-private/CMakeLists.txt
@@ -5,14 +5,14 @@ set(MINOR 0)
# Definition of the C++ files used to build the library - note that this
# is expanded at CMake time, so you have to rerun cmake if you add or remove
# a file (you can just run cmake . in the build directory)
-file(GLOB_RECURSE library "*.cc")
+file(GLOB_RECURSE library "*.cc" "*.mm")
file(GLOB_RECURSE headers "*.h")
# Create a library using the C++ files
add_library(apt-private SHARED ${library})
# Link the library and set the SONAME
-target_link_libraries(apt-private PUBLIC apt-pkg)
+target_link_libraries(apt-private PUBLIC apt-pkg "-framework Foundation")
set_target_properties(apt-private PROPERTIES VERSION ${MAJOR}.${MINOR})
set_target_properties(apt-private PROPERTIES SOVERSION ${MAJOR})
set_target_properties(apt-private PROPERTIES CXX_VISIBILITY_PRESET hidden)