summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily6
-rw-r--r--debian/changelog13
2 files changed, 16 insertions, 3 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 7ee7e46db..2d93a5ba4 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -74,7 +74,7 @@ check_size_constraints()
{
# min-age in days
MaxAge=0
- MinAge=1
+ MinAge=2
MaxSize=0
CacheDir="var/cache/apt"
CacheArchive="archives/"
@@ -110,7 +110,7 @@ check_size_constraints()
MinAge=$(($MinAge*24*60*60))
# reverse-sort by mtime
- for file in $(ls -rt $Cache/*.deb); do
+ for file in $(ls -rt $Cache/*.deb 2>/dev/null); do
du=$(du -s $Cache)
size=${du%%/*}
# check if the cache is small enough
@@ -125,7 +125,7 @@ check_size_constraints()
#echo "$file ($delta), $MinAge"
if [ $delta -le $MinAge ]; then
#echo "Skiping $file (delta=$delta)"
- continue
+ break
fi
fi
diff --git a/debian/changelog b/debian/changelog
index 1820b2cbf..87e713d3d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+apt (0.6.36) experimental; urgency=low
+
+ * Merge apt--mvo--0:
+ - apt-pkg/acquire-item.cc:
+ added "Acquire::BrokenProxy" that will force apt to always
+ re-get the Release.gpg file (for broken proxies)
+ - debian/apt.cron.daily:
+ MinAge is defaulting to 2 days now to prevent over-aggresive removal
+ - apt-pkg/cdrom.cc:
+ honor "Acquire::gpgv::Options" when verifying the signature (Ubuntu #8496)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 31 Mar 2005 20:37:11 +0200
+
apt (0.6.35) hoary; urgency=low
* Merge apt--mvo--0 (incorporates 0.6.34ubuntu1):