summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-07 18:22:14 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-10 16:11:43 +0200
commit06c2b40b9b9094f4f6391bd1d17cfc3725313070 (patch)
tree08f853ea0f6cf803c9ef91dbb90de55814833ac1 /CMakeLists.txt
parent173fa882cf3396ab6d2a9be53c6ea23eda225a1d (diff)
CMake: Add unit tests
Add support for our GTest based unit tests. By default, CMake will look in /usr/src/gtest for the external GTest project, but this can be overriden by defining GTEST_ROOT when invoking cmake. Gbp-Dch: ignore
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6baa8f14f..9e85e7b84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,8 @@
project(apt)
cmake_minimum_required(VERSION 3.3.0)
+enable_testing()
+
option(WITH_DOC "Build documentation." OFF)
option(USE_NLS "Localisation support." ON)