summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-07 15:45:36 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-10 16:10:54 +0200
commit33ee08e4dae7851bc3bcbb932a0563c38c933ead (patch)
treeb399d33a6055a9e7e42d65bef22bd18b3849bbca /CMakeLists.txt
parent427fc68b2bfcf8fbc37c0443581db6e000cadfee (diff)
CMake: Set PACKAGE_MAIL variable
This is needed in a lot of places. Also adjust config.h.in to use it instead of the bare email address. Gbp-Dch: ignore
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44b301cc2..6baa8f14f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,7 +108,8 @@ if (CMAKE_USE_PTHREADS_INIT)
endif()
# Configure some variables like package, version and architecture.
-set(PACKAGE "apt")
+set(PACKAGE ${PROJECT_NAME})
+set(PACKAGE_MAIL "APT Development Team <deity@lists.debian.org>")
execute_process(COMMAND dpkg-parsechangelog -SVersion -l${PROJECT_SOURCE_DIR}/debian/changelog
OUTPUT_VARIABLE PACKAGE_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)