summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-23 19:41:58 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-26 22:17:54 +0200
commit8757a0fdeee00ea6a7cc717188a0e129ad8a553c (patch)
treecd13473faa06c189bfd915b835af065e6a2abf11 /CMakeLists.txt
parentdd7758b9245275a31fde70218db9a531c5859c26 (diff)
Make directory paths configurable
This allows other vendors to use different paths, or to build your own APT in /opt for testing. Note that this uses + 1 in some places, as the paths we receive are absolute, but we need to strip of the initial /.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 18 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 189a8d570..916090866 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,6 +171,15 @@ if (NOT DEFINED COMMON_ARCH)
OUTPUT_VARIABLE COMMON_ARCH OUTPUT_STRIP_TRAILING_WHITESPACE)
endif()
+# Set various directories
+set(STATE_DIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/apt" CACHE PATH "Your /var/lib/apt")
+set(CACHE_DIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/cache/apt" CACHE PATH "Your /var/cache/apt")
+set(LOG_DIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/log/apt" CACHE PATH "Your /var/log/apt")
+set(CONF_DIR "${CMAKE_INSTALL_FULL_SYSCONFDIR}/apt" CACHE PATH "Your /etc/apt")
+set(LIBEXEC_DIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/apt" CACHE PATH "Your /usr/libexec/apt")
+set(BIN_DIR "${CMAKE_INSTALL_FULL_BINDIR}")
+
+
# Configure our configuration headers (config.h and apti18n.h)
configure_file(CMake/config.h.in ${PROJECT_BINARY_DIR}/include/config.h)
configure_file(CMake/apti18n.h.in ${PROJECT_BINARY_DIR}/include/apti18n.h)
@@ -197,13 +206,13 @@ endif()
# Create our directories.
install_empty_directories(
- ${CMAKE_INSTALL_FULL_SYSCONFDIR}/apt/apt.conf.d
- ${CMAKE_INSTALL_FULL_SYSCONFDIR}/apt/preferences.d
- ${CMAKE_INSTALL_FULL_SYSCONFDIR}/apt/sources.list.d
- ${CMAKE_INSTALL_FULL_SYSCONFDIR}/apt/trusted.gpg.d
- ${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/cache/apt/archives/partial
- ${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/apt/lists/partial
- ${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/apt/mirrors/partial
- ${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/lib/apt/periodic
- ${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/log/apt
+ ${CONF_DIR}/apt.conf.d
+ ${CONF_DIR}/preferences.d
+ ${CONF_DIR}/sources.list.d
+ ${CONF_DIR}/trusted.gpg.d
+ ${CACHE_DIR}/archives/partial
+ ${STATE_DIR}/lists/partial
+ ${STATE_DIR}/mirrors/partial
+ ${STATE_DIR}/periodic
+ ${LOG_DIR}
)