summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-23 18:42:52 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-23 18:46:10 +0200
commitac103d45f63bd9a57ff867a52c7c95616f6daf51 (patch)
treec83ae73cfd6c447bb21ef12ffcd87eb361f253af /CMakeLists.txt
parent9fb81c6e54a2fe05c0ad0b877fd32f30358e3877 (diff)
CMake: Do not add po/ if USE_NLS is OFF
Previously, we would have generated all the translations, but not turn them on in the code. Instead, move the Translation crap into po/ and disable po/ alltogether if USE_NLS if OFF.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b63cfe0e8..a43abfb78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,6 @@ endif()
# Include stuff
include(Misc)
-include(Translations)
include(CheckIncludeFiles)
include(CheckFunctionExists)
include(CheckStructHasMember)
@@ -144,11 +143,14 @@ add_subdirectory(doc)
add_subdirectory(dselect)
add_subdirectory(ftparchive)
add_subdirectory(methods)
-add_subdirectory(po)
add_subdirectory(test)
+if (USE_NLS)
+add_subdirectory(po)
+
# Link update-po4a into the update-po target
add_dependencies(update-po update-po4a)
+endif()
# Create our directories.
install_empty_directories(