summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-23 12:53:10 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-23 21:34:28 +0200
commitbb9fdfe45b1c06f87de857b6ed225b8509003976 (patch)
tree66571502a899b80693964caaf693fd8e652e5b68 /CMakeLists.txt
parentac103d45f63bd9a57ff867a52c7c95616f6daf51 (diff)
CMake: Define _WITH_GETLINE for FreeBSD
Gbp-Dch: ignore
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a43abfb78..fcb200571 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,6 +111,9 @@ check_function_exists(ptsname_r HAVE_PTSNAME_R)
check_function_exists(timegm HAVE_TIMEGM)
test_big_endian(WORDS_BIGENDIAN)
+# FreeBSD
+add_definitions(-D_WITH_GETLINE=1)
+
if (CMAKE_USE_PTHREADS_INIT)
set(HAVE_PTHREAD 1)
endif()