summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-23 14:13:24 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-26 15:49:14 +0200
commitc799c3efe43d7fde53ea4a3c5f976375607a2805 (patch)
tree1a20540a0402eb0d5569ac0671bc1ef5d5f4f7e2 /CMakeLists.txt
parentad5282bb0c97fd0254b20fb71a59d0f755c3ed65 (diff)
CMake: Add FindLZ4 and FindLZMA
This makes things work with /usr/local on FreeBSD. Gbp-Dch: ignore
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c41534ad..4f4c8b37e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,6 @@ include(CheckStructHasMember)
include(GNUInstallDirs)
include(TestBigEndian)
find_package(Threads)
-find_package(PkgConfig)
find_package(LFS REQUIRED)
# Add large file support
@@ -78,12 +77,13 @@ if (BZIP2_FOUND)
set(HAVE_BZ2 1)
endif()
-pkg_check_modules(LZMA liblzma)
+find_package(LZMA)
if (LZMA_FOUND)
set(HAVE_LZMA 1)
endif()
-pkg_check_modules(LZ4 liblz4)
+
+find_package(LZ4)
if (LZ4_FOUND)
set(HAVE_LZ4 1)
endif()