summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2019-05-03 14:51:40 +0000
committerJulian Andres Klode <jak@debian.org>2019-05-03 14:51:40 +0000
commit9ada8cb08b9d54291993118120712992302b6641 (patch)
treebcb3a3031af6f0ead0156932453869822567f913 /CMakeLists.txt
parente547a738922b434ae0bad32ead26a1a3c2095d1e (diff)
parent60cc44d160af02c49614653c97bfa3e4e5c9601d (diff)
Merge branch 'pu/systemd-inhibitor' into 'master'
Prevent shutdown while running dpkg See merge request apt-team/apt!60
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29cd30bc6..02bad9377 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,6 +117,11 @@ if (UDEV_FOUND)
set(HAVE_UDEV 1)
endif()
+find_package(Systemd)
+if (SYSTEMD_FOUND)
+ set(HAVE_SYSTEMD 1)
+endif()
+
find_package(Seccomp)
if (SECCOMP_FOUND)
set(HAVE_SECCOMP 1)