summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <julian.klode@canonical.com>2018-03-08 09:33:39 +0100
committerJulian Andres Klode <julian.klode@canonical.com>2018-03-12 08:56:59 +0100
commit4de4200ec2717e777bbf99ed82d1b4344f078ec2 (patch)
tree0b7e2c89802a69564f45e55907b698e63a84f205 /CMakeLists.txt
parent5206249ea92fccf9e812a2d373cbd2f16c623059 (diff)
apt-pkg: Add support for zstd
zstd is a compression algorithm developed by facebook. At level 19, it is about 6% worse in size than xz -6, but decompression is multiple times faster, saving about 40% install time, especially with eatmydata on cloud instances.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b723b0ead..a79ce99d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,12 @@ if (LZ4_FOUND)
set(HAVE_LZ4 1)
endif()
+find_package(Zstd REQUIRED)
+if (ZSTD_FOUND)
+ set(HAVE_ZSTD 1)
+endif()
+
+
find_package(Udev)
if (UDEV_FOUND)
set(HAVE_UDEV 1)