summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-09-10 11:37:13 +0200
committerJulian Andres Klode <jak@debian.org>2017-09-10 11:37:13 +0200
commit53f7fb3caad96bd7fb9af73d4ac964c67204798a (patch)
treec7bb8d5b3394f200180f4c78c33c503961be93eb /CMakeLists.txt
parentb13861fa687cf3a2af97a5beb0c0642d9bee8f8c (diff)
CMake: Mark BZip2, LZMA, and LZ4 as required
We do not actually test without these libraries, and it likely would not build without them due to them being NOTFOUND and CMake exiting with an error, so let's just mark them as required.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d45409e56..400fdd69e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,18 +103,18 @@ if (ZLIB_FOUND)
endif()
-find_package(BZip2)
+find_package(BZip2 REQUIRED)
if (BZIP2_FOUND)
set(HAVE_BZ2 1)
endif()
-find_package(LZMA)
+find_package(LZMA REQUIRED)
if (LZMA_FOUND)
set(HAVE_LZMA 1)
endif()
-find_package(LZ4)
+find_package(LZ4 REQUIRED)
if (LZ4_FOUND)
set(HAVE_LZ4 1)
endif()