summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-09-24 20:33:49 +0200
committerJulian Andres Klode <jak@debian.org>2017-09-24 20:36:41 +0200
commit5e770a07c8fd649340e83725f6d07b94c361e87c (patch)
treef7acc2299bc05d52a26d3507f37cfd0bd8b5ee6f /CMakeLists.txt
parent6d44f502d102411325bb52efa7caa76c1054d2dd (diff)
Drop curl method and apt-transport-https package
This automatically removes any old apt-transport-https, as apt now Breaks it unversioned.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e5a78706b..04a8be22a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,22 +75,6 @@ if (BERKELEY_DB_FOUND)
set(HAVE_BDB 1)
endif()
-
-# apt-transport-https dependencies
-option(WITH_CURL "Build curl-based methods" ON)
-option(FORCE_CURL "Use curl-based methods" OFF)
-if (FORCE_CURL AND NOT WITH_CURL)
- message(FATAL_ERROR "Cannot set FORCE_CURL=ON with WITH_CURL=OFF")
-endif()
-if (WITH_CURL)
- find_package(CURL REQUIRED)
- if (CURL_FOUND)
- set(HAVE_CURL 1)
- endif()
-else()
- set(HAVE_CURL 0)
-endif()
-
find_package(GnuTLS REQUIRED)
if (GNUTLS_FOUND)
set(HAVE_GNUTLS 1)