summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-07-20 20:50:05 +0200
committerJulian Andres Klode <jak@debian.org>2017-07-20 20:50:05 +0200
commitb28636e54f682dc65aef169f201a34a8e2893369 (patch)
tree43beb2fbe7b87d1dc068ca05e6e49b0b311347e6 /CMakeLists.txt
parente0204f0236697bdc1b2392be5e141de9ec0c184e (diff)
Use C++11 threading support instead of pthread
This makes the code easier to read.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49650bc0c..6d41f728a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,7 @@ include(CheckFunctionExists)
include(CheckStructHasMember)
include(GNUInstallDirs)
include(TestBigEndian)
-find_package(Threads)
+find_package(Threads REQUIRED)
find_package(LFS REQUIRED)
find_package(Iconv REQUIRED)
@@ -146,10 +146,6 @@ test_big_endian(WORDS_BIGENDIAN)
# FreeBSD
add_definitions(-D_WITH_GETLINE=1)
-if (CMAKE_USE_PTHREADS_INIT)
- set(HAVE_PTHREAD 1)
-endif()
-
CHECK_INCLUDE_FILES(machine/endian.h HAVE_MACHINE_ENDIAN_H)
CHECK_INCLUDE_FILES(sys/endian.h HAVE_SYS_ENDIAN_H)
CHECK_INCLUDE_FILES(endian.h HAVE_ENDIAN_H)