summaryrefslogtreecommitdiff
path: root/apt-inst/CMakeLists.txt
diff options
context:
space:
mode:
authorCorentin Noël <corentin.noel@collabora.com>2018-06-03 16:37:44 +0100
committerCorentin Noël <corentin.noel@collabora.com>2019-03-08 19:13:06 +0100
commit7c461f0396d413acb9a950f3df9ea6d062896cd7 (patch)
tree7e6ee54c377af089e9ab788ef963c3a34054aae4 /apt-inst/CMakeLists.txt
parentf541aec06bce1ccac98dabe61137b56ed563e0e9 (diff)
Add pkg-config files for the apt-pkg and apt-inst libraries
Closes: #439121
Diffstat (limited to 'apt-inst/CMakeLists.txt')
-rw-r--r--apt-inst/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/apt-inst/CMakeLists.txt b/apt-inst/CMakeLists.txt
index 55950679a..e4e91e493 100644
--- a/apt-inst/CMakeLists.txt
+++ b/apt-inst/CMakeLists.txt
@@ -12,6 +12,8 @@ set(APT_INST_MAJOR ${MAJOR} PARENT_SCOPE)
file(GLOB_RECURSE library "*.cc")
file(GLOB_RECURSE headers "*.h")
+configure_file(apt-inst.pc.in ${CMAKE_CURRENT_BINARY_DIR}/apt-inst.pc @ONLY)
+
# Create a library using the C++ files
add_library(apt-inst SHARED ${library})
@@ -25,4 +27,5 @@ add_version_script(apt-inst)
# Install the library and the headers
install(TARGETS apt-inst LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
install(FILES ${headers} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/apt-pkg)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/apt-inst.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
flatify(${PROJECT_BINARY_DIR}/include/apt-pkg/ "${headers}")