summaryrefslogtreecommitdiff
path: root/apt-private/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-01-17 14:33:02 +0100
committerJulian Andres Klode <jak@debian.org>2017-01-17 14:33:02 +0100
commitb59a8c6e29015c4d19c4b39a63b328af7d87d1ee (patch)
treebb437e51b05bf67409e70d96034ae970f891880b /apt-private/CMakeLists.txt
parent994515e689dcc5f963f5fed58284831750a5da03 (diff)
CMake: Document that the globs are expanded during CMake
This will avoid people from thinking that they have to do nothing when they change the set of files. Gbp-Dch: ignore
Diffstat (limited to 'apt-private/CMakeLists.txt')
-rw-r--r--apt-private/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/apt-private/CMakeLists.txt b/apt-private/CMakeLists.txt
index 6de9e0281..5dda36c92 100644
--- a/apt-private/CMakeLists.txt
+++ b/apt-private/CMakeLists.txt
@@ -2,7 +2,9 @@
set(MAJOR 0.0)
set(MINOR 0)
-# Definition of the C++ files used to build the library
+# Definition of the C++ files used to build the library - note that this
+# is expanded at CMake time, so you have to rerun cmake if you add or remove
+# a file (you can just run cmake . in the build directory)
file(GLOB_RECURSE library "*.cc")
file(GLOB_RECURSE headers "*.h")