summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2014-03-12 14:39:18 +0100
committerDavid Kalnischkies <david@kalnischkies.de>2014-03-13 14:00:38 +0100
commit7f350a377e0c65a656b9b5437e27d037fd742901 (patch)
treeda88009c697866f376cdbcd39dabc381b29ca9ba /configure.ac
parent0ec6b98b24939100a6d4c333abe5bc62a4455f9f (diff)
use liblzma-dev to provide xz/lzma support
We have xz/lzma support for a while, but only via an external binary provided by xz-utils. Now that the Debian archive provides xz by default and dpkg pre-depends on the library provided by liblzma-dev we can switch now to use this library as well to avoid requiring an external binary. For now the binary is in a prio:required package, but this might change in the future. API wise it is quiet similar to bz2 code expect that it doesn't provide file I/O methods, so we piece this together on our own.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40556ee54..4f782f873 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,13 @@ if test "x$HAVE_BZ2" = "xyes"; then
AC_DEFINE(HAVE_BZ2)
fi
+HAVE_LZMA=no
+AC_CHECK_LIB(lzma, lzma_easy_encoder,[AC_CHECK_HEADER(lzma.h, [HAVE_LZMA=yes], [])], [])
+AC_SUBST(HAVE_LZMA)
+if test "x$HAVE_LZMA" = "xyes"; then
+ AC_DEFINE(HAVE_LZMA)
+fi
+
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
dnl First check against the full canonical canoncial-system-type in $target