summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2015-11-03 11:10:53 +0100
committerJulian Andres Klode <jak@debian.org>2015-11-03 11:10:53 +0100
commit959568175b0bd9078074b17ffbb2e16545c6cf14 (patch)
tree4b859f49241e47c9a521305632b879e04c3e8632 /configure.ac
parent05e7d4eee1c1089762538b4d9a7494652b1ee23c (diff)
configure.ac: Run autoupdate
Gbp-Dch: ignore
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8bf87754b..83c29b4f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,8 +12,9 @@ dnl not used but STL is.
dnl 'make -f Makefile startup' will generate the configure file from
dnl configure.ac correctly and can be run at any time
-AC_PREREQ(2.50)
-AC_INIT(configure.ac)
+AC_PREREQ([2.69])
+AC_INIT
+AC_CONFIG_SRCDIR([configure.ac])
AC_CONFIG_AUX_DIR(buildlib)
AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in)
@@ -28,12 +29,12 @@ AC_SUBST(PACKAGE_VERSION)
AC_SUBST(PACKAGE_MAIL)
dnl Check the archs, we want the target type.
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
dnl Check our C compiler
-AC_CHECK_TOOL_PREFIX
+
AC_PROG_CC
-AC_ISC_POSIX
+AC_SEARCH_LIBS([strerror],[cposix])
dnl check for large file support and enable it if possible
dnl do this early as other stuff might depend on it
@@ -209,4 +210,6 @@ fi
AC_SUBST(USE_NLS)
AC_PATH_PROG(BASH, bash)
-AC_OUTPUT(environment.mak:buildlib/environment.mak.in makefile:buildlib/makefile.in doc/Doxyfile:doc/Doxyfile.in,make -s dirs)
+AC_CONFIG_FILES([environment.mak:buildlib/environment.mak.in makefile:buildlib/makefile.in doc/Doxyfile:doc/Doxyfile.in])
+AC_CONFIG_COMMANDS([default],[make -s dirs],[])
+AC_OUTPUT