summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2007-07-25 20:27:40 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2007-07-25 20:27:40 -0300
commit0fbb494b343342af795a17a56d4b915499c52ed9 (patch)
tree3b78efb28d18b34922825b7ed577dca03b41a7f6 /configure.in
parentba1a544bcc8ee9147c45f65ceb23b911f3d235e9 (diff)
* Applied patch from Guillem Jover <guillem.jover@nokia.com> to use
dpkg-architecture to get the host architecture (closes: #407187)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 9bb1a8baf..ad913f53e 100644
--- a/configure.in
+++ b/configure.in
@@ -81,12 +81,9 @@ dnl This is often the dpkg architecture string.
dnl First check against the full canonical canoncial-system-type in $target
dnl and if that fails, just look for the cpu
AC_MSG_CHECKING(system architecture)
-archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/systemtable`"
+archset="`dpkg-architecture -qDEB_HOST_ARCH`"
if test "x$archset" = "x"; then
- archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target_cpu\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/archtable`"
- if test "x$archset" = "x"; then
- AC_MSG_ERROR(failed: use --host= or check buildlib/archtable)
- fi
+ AC_MSG_ERROR([failed: use --host= or output from dpkg-architecture])
fi
AC_MSG_RESULT($archset)
AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")
@@ -94,7 +91,7 @@ AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")
dnl Get a common name for the host OS - this is primarily only for HURD and is
dnl non fatal if it fails
AC_MSG_CHECKING(system OS)
-osset="`awk \" ! /^#|^\\\$/ {if (match(\\\"$target_vendor-$target_os\\\",\\\$1)) {print \\\$2; exit}}\" $srcdir/buildlib/ostable`"
+osset="`dpkg-architecture -qDEB_HOST_ARCH_OS`"
AC_MSG_RESULT($osset)
AC_DEFINE_UNQUOTED(COMMON_OS,"$osset")