summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2012-04-05 15:18:03 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2012-04-05 15:18:03 +0200
commit7efb8c8ef10c1d0b9479c24a6a5b4e96fc0e6286 (patch)
tree0b707ca7c07780eb20f4ad5028936fc371f99b8e /configure.in
parentbacc49dfe278f16859b43d159e7042e9fc22d603 (diff)
detect zlib correctly. We still don't allow to build without it to remain
compatible with users accessing it directly, but this prepares for a drop of this strict requirement in the future
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 78ad06b72..ec98ba4ef 100644
--- a/configure.in
+++ b/configure.in
@@ -89,7 +89,7 @@ AC_CHECK_LIB(curl, curl_easy_init,
AC_SUBST(BDBLIB)
AC_CHECK_LIB(z, gzopen,
- [AC_CHECK_HEADER(zlib.h, [], AC_MSG_ERROR([failed: zlib.h not found]))],
+ [AC_CHECK_HEADER(zlib.h, [AC_DEFINE(HAVE_ZLIB)], AC_MSG_ERROR([failed: zlib.h not found]))],
AC_MSG_ERROR([failed: Need libz]))
dnl Converts the ARCH to be something singular for this general CPU family