summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2012-04-05 20:51:36 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2012-04-05 20:51:36 +0200
commitc4997486bffc76e2581e9072bff05eba0feeb29c (patch)
tree7966bc2e5b737a7dedc6aca8eaff87ab8edaa0f9 /configure.in
parent8dd623dbd616ee23dc96a2c99a4415b153dd7290 (diff)
- add libbz2-dev as new build-dependency
- remove the libz-dev alternative from zlib1g-dev build-dependency - do the same for bz2 builtin if available * apt-pkg/contrib/fileutl.cc: - use libz2 library for (de)compression instead of the bzip2 binary as the first is a dependency of dpkg and the later just priority:optional so we gain 'easier' access to bz2-compressed Translation files this way
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ec98ba4ef..b974b9eb9 100644
--- a/configure.in
+++ b/configure.in
@@ -88,9 +88,21 @@ AC_CHECK_LIB(curl, curl_easy_init,
AC_SUBST(BDBLIB)
+HAVE_ZLIB=no
AC_CHECK_LIB(z, gzopen,
- [AC_CHECK_HEADER(zlib.h, [AC_DEFINE(HAVE_ZLIB)], AC_MSG_ERROR([failed: zlib.h not found]))],
+ [AC_CHECK_HEADER(zlib.h, [HAVE_ZLIB=yes], AC_MSG_ERROR([failed: zlib.h not found]))],
AC_MSG_ERROR([failed: Need libz]))
+AC_SUBST(HAVE_ZLIB)
+if test "x$HAVE_ZLIB" = "xyes"; then
+ AC_DEFINE(HAVE_ZLIB)
+fi
+
+HAVE_BZ2=no
+AC_CHECK_LIB(bz2, BZ2_bzopen,[AC_CHECK_HEADER(bzlib.h, [HAVE_BZ2=yes], [])], [])
+AC_SUBST(HAVE_BZ2)
+if test "x$HAVE_BZ2" = "xyes"; then
+ AC_DEFINE(HAVE_BZ2)
+fi
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.