summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:55:05 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:55:05 +0000
commit83ab33fcc08192f31fc02e680b84aa8489f76c50 (patch)
treef4a232a1ae4ebe6cdb64b89f3a41664680515a66 /configure.in
parent67db871e3a0a0c207d4675ca046f2d2b796cfb6d (diff)
Doc fix
Author: jgg Date: 1999-10-31 06:32:27 GMT Doc fix
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in41
1 files changed, 21 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 1525e961b..8e052ed49 100644
--- a/configure.in
+++ b/configure.in
@@ -83,35 +83,36 @@ AC_CACHE_CHECK([for C9x integer types],c9x_ints,[
[uint8_t Foo1;uint16_t Foo2;uint32_t Foo3;uint64_t Foo],
c9x_ints=yes,c9x_ints=no)])
-dnl We do not need this if we have inttypes..
- if test x"$c9x_ints" = x"no"; then
- dnl Check the sizes etc. of the architecture
- changequote(,)
- if archline="`sed -ne 's/^'$archset':[ ]\+\(.*\)/\1/gp' $srcdir/buildlib/sizetable`"; then
- changequote([,])
- set $archline
- if test "$1" = "little"; then
- ac_cv_c_bigendian=no
- else
- ac_cv_c_bigendian=yes
- fi
- size_char=$2
- size_int=$3
- size_short=$4
- size_long=$5
+dnl Check the sizes etc. of the architecture
+changequote(,)
+if archline="`sed -ne 's/^'$archset':[ ]\+\(.*\)/\1/gp' $srcdir/buildlib/sizetable`"; then
+ changequote([,])
+ set $archline
+ if test "$1" = "little"; then
+ ac_cv_c_bigendian=no
+ else
+ ac_cv_c_bigendian=yes
fi
+ size_char=$2
+ size_int=$3
+ size_short=$4
+ size_long=$5
+fi
- if test "$cross_compiling" = "yes" -a "$archline" = ""; then
- AC_MSG_ERROR(When cross compiling, architecture must be present in sizetable)
- fi
- AC_C_BIGENDIAN
+if test "$cross_compiling" = "yes" -a "$archline" = ""; then
+ AC_MSG_ERROR(When cross compiling, architecture must be present in sizetable)
+fi
+AC_C_BIGENDIAN
+dnl We do not need this if we have inttypes..
+if test x"$c9x_ints" = x"no"; then
AC_CHECK_SIZEOF(char,$size_char)
AC_CHECK_SIZEOF(int,$size_int)
AC_CHECK_SIZEOF(short,$size_short)
AC_CHECK_SIZEOF(long,$size_long)
fi
+
dnl Check for debiandoc
AC_CHECK_PROG(DEBIANDOC_HTML,debiandoc2html,"yes","")
AC_CHECK_PROG(DEBIANDOC_TEXT,debiandoc2text,"yes","")