summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2007-06-06 19:40:06 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2007-06-06 19:40:06 +0200
commit0fa17428d9905865fe2d586f3787ebc590ca5a24 (patch)
tree16091906b2bb8dbba36ac4f31d88433944eedf3b /configure.in
parent93e72e9cc0ba1877044af0b9f823e1c3352183ec (diff)
* buildlib/systemtable, configure.in:
added new buildlib/systemtable to map complette canonical system type to apt architecture and add support for lpia
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c7bf253d1..4aa56e117 100644
--- a/configure.in
+++ b/configure.in
@@ -18,7 +18,7 @@ AC_CONFIG_AUX_DIR(buildlib)
AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in)
dnl -- SET THIS TO THE RELEASE VERSION --
-AC_DEFINE_UNQUOTED(VERSION,"0.6.46.5")
+AC_DEFINE_UNQUOTED(VERSION,"0.6.47")
PACKAGE="apt"
AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE")
AC_SUBST(PACKAGE)
@@ -78,10 +78,15 @@ AC_SUBST(BDBLIB)
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
+dnl First check against the full canonical canoncial-system-type in $target
+dnl and if that fails, just look for the cpu
AC_MSG_CHECKING(system architecture)
-archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target_cpu\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/archtable`"
+archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/systemtable`"
if test "x$archset" = "x"; then
+ archset="`awk \" ! /^#|^\\\$/ { if(match(\\\"$target_cpu\\\",\\\"^\\\"\\\$1\\\"\\\$\\\")) {print \\\$2; exit}}\" $srcdir/buildlib/archtable`"
+ if test "x$archset" = "x"; then
AC_MSG_ERROR(failed: use --host= or check buildlib/archtable)
+ fi
fi
AC_MSG_RESULT($archset)
AC_DEFINE_UNQUOTED(COMMON_CPU,"$archset")