summaryrefslogtreecommitdiff
path: root/debian/apt.cron.daily
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2014-02-27 22:52:34 +0100
committerMichael Vogt <mvo@debian.org>2014-02-27 22:52:34 +0100
commitfce69e7a0f38299c57ef96ae1c1dd9a5379bfd5a (patch)
treebe7d18baa836e9df166ec63f6c9fe6f94bb84b40 /debian/apt.cron.daily
parenta5e790985752c6820e08e7a7e650e1607fa826e4 (diff)
parentfc104da6a583736223b2f941e43a05ea26b63a7d (diff)
Merge branch 'debian/sid' into debian/experimental
Conflicts: apt-private/private-list.cc configure.ac debian/apt.install.in debian/changelog
Diffstat (limited to 'debian/apt.cron.daily')
-rw-r--r--debian/apt.cron.daily10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 2665b6579..71ac76555 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -34,7 +34,7 @@
# APT::Archives::MinAge "2"; (old, deprecated)
# APT::Periodic::MinAge "2"; (new)
# - Set minimum age of a package file. If a file is younger it
-# will not be deleted (0=disable). Usefull to prevent races
+# will not be deleted (0=disable). Useful to prevent races
# and to keep backups of the packages for emergency.
#
# APT::Archives::MaxSize "0"; (old, deprecated)
@@ -197,11 +197,11 @@ check_size_constraints()
delta=$(($now-$ctime))
fi
if [ $delta -le $MinAge ]; then
- debug_echo "skip remove by archive size: $file, delta=$delta < $MinAgeSec"
+ debug_echo "skip remove by archive size: $file, delta=$delta < $MinAge"
break
else
# delete oldest file
- debug_echo "remove by archive size: $file, delta=$delta >= $MinAgeSec (sec), size=$size >= $MaxSize"
+ debug_echo "remove by archive size: $file, delta=$delta >= $MinAge (sec), size=$size >= $MaxSize"
rm -f $file
fi
fi
@@ -375,7 +375,7 @@ fi
check_power || exit 0
# check if we can lock the cache and if the cache is clean
-if which apt-get >/dev/null && ! eval apt-get check -f $XAPTOPT $XSTDERR ; then
+if which apt-get >/dev/null && ! eval apt-get check $XAPTOPT $XSTDERR ; then
debug_echo "error encountered in cron job with \"apt-get check\"."
exit 0
fi
@@ -384,7 +384,7 @@ fi
now=$(date +%s)
# Support old Archive for compatibility.
-# Document only Periodic for all controling parameters of this script.
+# Document only Periodic for all controlling parameters of this script.
UpdateInterval=0
eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists)