summaryrefslogtreecommitdiff
path: root/debian/apt.cron.daily
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2008-05-05 11:03:16 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2008-05-05 11:03:16 +0200
commit549da1a850f0fd50e0a55415452ecaa735d49451 (patch)
tree312bc5525fc98d2c25780e3479b7223044596388 /debian/apt.cron.daily
parent1171258afb052c3ddcb4e5dc3f19b4ec1b29e4b9 (diff)
parent8f6aa8efa522c90959fb827a8618f02f41e0a2cd (diff)
* Mark a message from dselect backend as translatable
Thanks to Frédéric Bothamy for the patch Closes: #322470 * Simplified Chinese updated. Closes: #473360 * Catalan fixes. Closes: #387141 * Typo fix in Greek translation. Closes: #479122 * French updated. * Thai updated. Closes: #479313 * Italian updated. Closes: #479326 * Polish updated. Closes: #479342 * Bulgarian updated. Closes: #479379 * Finnish updated. Closes: #479403 * Korean updated. Closes: #479426 * Basque updated. Closes: #479452 * Add missing build-depends back from build-depends-indep field. Closes: #478231 * Make cron script quiet if cache is locked. Thanks to Ted Percival <ted@midg3t.net> for the patch. Closes: #459344 * Add timeout support for https. Thanks to Andrew Martens <andrew.martens@strangeloopnetworks.com> for the patch. * Add support for --no-download on apt-get update. Closes: #478517 - Vietnamese updated. Closes: #479008 - Enable more complete debugging information when Debug::pkgAutoRemove is set. * debian/rules: - Add missing Build-Depends-Indep on xsltproc, docbook-xsl, and xmlto.
Diffstat (limited to 'debian/apt.cron.daily')
-rw-r--r--debian/apt.cron.daily5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index ec53a7f2f..1ca830c93 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -193,9 +193,10 @@ if which on_ac_power >/dev/null; then
fi
# check if we can lock the cache and if the cache is clean
+# There's a reasonable chance that someone is already running an apt
+# frontend that has locked the cache, so exit quietly if it is locked.
if ! apt-get check -q -q 2>/dev/null; then
- echo "$0: could not lock the APT cache"
- exit 1
+ exit 0
fi
# sleep random amount of time