summaryrefslogtreecommitdiff
path: root/debian/preinst
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2013-12-05 08:24:00 +0100
committerMichael Vogt <mvo@debian.org>2013-12-05 08:24:00 +0100
commit44633bd7cac1ce68d4e475285a0f45b7a8952a7f (patch)
tree3e3af83bb955b9f49f38239d490b5173bb0b9ac4 /debian/preinst
parentb10b0c4aac5d0648125d4203eea6900032efb7ba (diff)
parent7014e1482942d00b66eb30061b0cf5d2a7b3ebf3 (diff)
Merge branch 'debian/sid' into ubuntu/master
Conflicts: apt-pkg/deb/dpkgpm.cc cmdline/apt-key.in debian/control doc/apt-key.8.xml doc/makefile doc/po/apt-doc.pot doc/po/de.po doc/po/es.po doc/po/fr.po doc/po/it.po doc/po/ja.po doc/po/pl.po doc/po/pt.po doc/po/pt_BR.po
Diffstat (limited to 'debian/preinst')
-rwxr-xr-xdebian/preinst32
1 files changed, 0 insertions, 32 deletions
diff --git a/debian/preinst b/debian/preinst
deleted file mode 100755
index 985ad9b84..000000000
--- a/debian/preinst
+++ /dev/null
@@ -1,32 +0,0 @@
-#! /bin/sh
-
-set -e
-
-# dpkg does this for us while we are upgrading..
-#if [ "$1" = "upgrade" -a -L /var/state/apt -a -e /var/lib/apt -a ! -L /var/state/apt ] && dpkg --compare-versions "$2" ">=" "0.4.10"; then
-# rm /var/state/apt
-#fi
-
-if [ "$1" = "upgrade" -o "$1" = "install" -a "$2" != "" ]; then
- if [ ! -e /var/lib/apt -a -e /var/state/apt ]; then
- # upgrading from /var/state/apt using apt.
- # it's probably running now so we want to ensure /var/state/apt
- # is still valid afterwards. and since we're upgrading
-
- if [ -x /usr/bin/perl -a -d /var/state/apt -a ! -L /var/state/apt ] &&
- perl -e 'exit 1 if ((stat("/var/lib"))[0] != (stat("/var/state/apt"))[0])'
- then
- # same fs, we can mv it
- mv /var/state/apt /var/lib/apt
- ln -s ../lib/apt /var/state/apt
- # note that this symlink (/var/state/apt) will be removed when
- # dpkg finishes unpacking the apt we're about to install; this is okay
- else
- # scary, let's just symlink it and hope
- ln -s /var/state/apt /var/lib/apt
- fi
- fi
- touch /var/lib/apt/lists/partial/.delete-me-later || true
-fi
-
-#DEBHELPER#