summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2009-08-28 10:06:03 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2009-08-28 10:06:03 +0200
commit86d9e9635a23c7ecfe2de7f440a6acce320067bc (patch)
tree49cdacfb0df096ddf14c3a9c0af8f0682cb67249 /debian/rules
parent97c17a01c7722f08e0cebf938c12a010b96220b7 (diff)
parentb01390eaa5750f28f258308b546f398ea5d89e3c (diff)
merge with my po4a branch & update both pot's
Thanks again for the initial patch from KURASAWA Nozomu and for the improvements and cleanups done by Nicolas François to get po4a up and running for apt man page translations!
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index f1eb62b57..d19531dfc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -186,6 +186,7 @@ apt-doc: build-doc
# Build architecture-dependent files here.
binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
apt: build build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -226,7 +227,7 @@ apt: build build-doc debian/shlibs.local
rm -f po/*.pot
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installman -p$@
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
dh_installcron -p$@
dh_installdocs -p$@
dh_installchangelogs -p$@
@@ -269,6 +270,7 @@ libapt-pkg-dev: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
apt-utils: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -284,7 +286,7 @@ apt-utils: build debian/shlibs.local
dh_installexamples -p$@
# Install the man pages..
- dh_installman -p$@
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
dh_installchangelogs -p$@
dh_strip -p$@