summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2005-08-08 22:38:27 +0000
committerMichael Vogt <michael.vogt@ubuntu.com>2005-08-08 22:38:27 +0000
commitdc2cd7d5c4889a6cc09b5a5a9eb35c74f86c2712 (patch)
treefb68b5f06efb992d9bb537b61e8ffae7d678ef2b /debian/rules
parent7ef96224b8f697b74089ab8f47688f28e5025b42 (diff)
* removed the lsb_release build patch (nobody except me seems to like it)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 2 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 0787c0c8b..b3f72bb7f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,9 +17,6 @@
export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-# apt can be build from the same source on debian and ubuntu
-DIST = $(shell lsb_release -i -s)
-
# FOR AUTOCONF 2.52 AND NEWER ONLY
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build $(DEB_HOST_GNU_TYPE)
@@ -114,7 +111,7 @@ build/configure-stamp: configure
cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
touch $@
-build/build-stamp: build/configure-stamp patch
+build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
$(MAKE) binary
touch $@
@@ -124,7 +121,7 @@ build/build-doc-stamp: build/configure-stamp
$(MAKE) doc
touch $@
-clean: unpatch
+clean:
dh_testdir
# dh_testroot
-$(MAKE) clean
@@ -334,17 +331,6 @@ cvs-mkul:
-mkdir -p ../upload-$(APT_DEBVER)
cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
-patch: patch-stamp
-patch-stamp:
- cp debian/patches/00list.$(DIST) debian/patches/00list
- dpatch apply-all
- touch patch-stamp
-
-unpatch:
- cp debian/patches/00list.$(DIST) debian/patches/00list
- dpatch deapply-all
- rm -rf patch-stamp debian/patched
-
arch-build:
rm -rf debian/arch-build
mkdir -p debian/arch-build/apt-$(APT_DEBVER)