summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2006-12-14 12:07:24 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2006-12-14 12:07:24 +0100
commitdc4002d8c3c687e6614d01b34e4b6aa929411ea9 (patch)
tree8a842af457cfb159741b6c84ee7ab6fc094b88e7 /debian/rules
parent7570b65d5eae54c51689121a317351a1cd42e64d (diff)
parent19ec5723caa6ea6ab196a9e960c769ded4ee0d28 (diff)
* merged with apt--mvo
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 333d4ad5b..4e7490bed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')