summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2006-09-30 16:18:09 +0200
committerMichael Vogt <egon@bottom>2006-09-30 16:18:09 +0200
commitdd2fdae926c586c6e19ec7d66cc0cb18932d7036 (patch)
tree74b5adfb68810f491c5ec53d029292bd9882b569 /debian/rules
parentb3b73d89b698cba8e91b0e6c0807afecc6191a98 (diff)
parent47e6f3ac05262f452eddbb59657cfc2465b5c62e (diff)
* merged from mainline
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index a8bf88762..02ee734bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')