summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:04:28 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:04:28 +0000
commiteef77d3710f881aad843c62e5a4d0586e03ab229 (patch)
treec44fa246a32f9f899160fc8e766c158b8be7d516 /debian/rules
parentd1cd75b4993d5134d85f3166d26fd738f6d2838b (diff)
* Avoid clobbering configure.in if sed fails
Author: mdz Date: 2003-12-24 22:55:30 GMT * Avoid clobbering configure.in if sed fails
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index dd2c993ca..0ac423c92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.61 2003/12/21 00:37:58 mdz Exp $
+# $Id: rules,v 1.62 2003/12/24 22:55:30 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -53,7 +53,7 @@ endif
ifneq ($(APT_DEBVER),$(APT_CONFVER))
.PHONY: configure.in
configure.in:
- sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+ sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
else
configure.in:
endif