summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2010-05-04 21:48:38 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2010-05-04 21:48:38 +0200
commit70371bc8163cab22dec315f73db087095a011669 (patch)
treedc05b2b6c4addf0c604ee7c7114733aa35ea2670 /debian/rules
parent827d04d3b2ed62d4e666698e639af6fbb3199581 (diff)
* debian/rules:
- spell out some less known options to reduce manpage consulation-rate - Use POSIX command substitution: $(<command sequence>) - Remove EOL whitespace (Closes: #577804)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules69
1 files changed, 30 insertions, 39 deletions
diff --git a/debian/rules b/debian/rules
index 2fe6ed69c..ba19f2526 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,7 +47,7 @@ BASE=.
ifdef BUILD
BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
endif
BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
@@ -82,9 +82,9 @@ LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
debian/shlibs.local: apt-pkg/makefile
- # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+ # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
- # the right overrides..
+ # the right overrides…
rm -rf $@ $@.apt $@.apt-utils
echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
@@ -94,8 +94,8 @@ debian/shlibs.local: apt-pkg/makefile
echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
-build: build/build-stamp
-build-doc: build/build-doc-stamp
+build: build/build-stamp
+build-doc: build/build-doc-stamp
# Note that this is unconditionally done first as part of loading environment.mak
# The true is needed to force make to reload environment.mak after running
@@ -123,10 +123,8 @@ build/build-doc-stamp: build/configure-stamp
clean:
dh_testdir
-# dh_testroot
- [ -f Makefile ] && $(MAKE) clean
- [ -f Makefile ] && $(MAKE) distclean
+ [ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
# Add here commands to clean up after the build process.
@@ -141,22 +139,19 @@ libapt-pkg-doc: build-doc debian/shlibs.local
dh_installdirs -p$@
#
# libapt-pkg-doc install
-#
- dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
- $(BLD)/docs/files* $(BLD)/docs/method* \
- doc/libapt-pkg2_to_3.txt doc/style.txt
+#
+ dh_installdocs -p$@ $(BLD)/docs/design* \
+ $(BLD)/docs/dpkg-tech* \
+ $(BLD)/docs/files* \
+ $(BLD)/docs/method* \
+ doc/libapt-pkg2_to_3.txt \
+ doc/style.txt
dh_installexamples -p$@
-# dh_installmenu -p$@
-# dh_installinit -p$@
-# dh_installcron -p$@
-# dh_installman -p$@
-# dh_undocumented -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
-# dh_suidregister -p$@
dh_installdeb -p$@
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
@@ -170,8 +165,10 @@ apt-doc: build-doc
# apt-doc install
#
# Copy the guides
- dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
- $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
+ dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+ $(BLD)/docs/guide*.html \
+ $(BLD)/docs/offline*.text \
+ $(BLD)/docs/offline*.html
dh_installchangelogs -p$@
dh_compress -p$@
dh_fixperms -p$@
@@ -214,7 +211,6 @@ apt: build build-doc debian/shlibs.local
cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
-# head -n 500 ChangeLog > debian/ChangeLog
# copy lintian override
cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
@@ -232,9 +228,9 @@ apt: build build-doc debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
+ dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
@@ -253,16 +249,11 @@ libapt-pkg-dev: build debian/shlibs.local
cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
dh_installdocs -p$@
-# dh_installmenu -p$@
-# dh_installinit -p$@
-# dh_installcron -p$@
-# dh_installman -p$@
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
-# dh_suidregister -p$@
dh_installdeb -p$@
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
@@ -290,9 +281,9 @@ apt-utils: build debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+ dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+ dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
@@ -304,7 +295,7 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
dh_installdirs -p$@
# install the method
- mkdir -p debian/$@/usr/lib/apt/methods
+ mkdir --parents debian/$@/usr/lib/apt/methods
cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
dh_installdocs -p$@ debian/apt-transport-https.README
@@ -318,7 +309,7 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib
+ dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib
dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
@@ -341,7 +332,7 @@ l33ch-stamp: super-l33ch
touch $@
really-clean: clean
- -find -name Makefile.in -print0 | xargs -0r rm -f
+ -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
find -name ChangeLog | xargs rm -f
rm -f l33ch-stamp
@@ -350,7 +341,7 @@ binary: binary-indep binary-arch
# Done by the uploader.
-#cvs update..
+#cvs update…
#edit debian/changelog
# configure.in has the version automatically updated now.
# edit configure.in
@@ -361,18 +352,18 @@ CVS_ROOT=$(shell cat CVS/Root)
CVS_MODULE=$(shell cat CVS/Repository)
cvs-build:
rm -rf debian/cvs-build
- mkdir -p debian/cvs-build
+ mkdir --parents debian/cvs-build
(cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
$(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
(cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
cvs-mkul:
- -mkdir -p ../upload-$(APT_DEBVER)
- cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+ -mkdir --parents ../upload-$(APT_DEBVER)
+ cp $(find debian/cvs-build -maxdepth 1 -type f) ../upload-$(APT_DEBVER)
arch-build:
rm -rf debian/arch-build
- mkdir -p debian/arch-build/apt-$(APT_DEBVER)
- tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
+ mkdir --parents debian/arch-build/apt-$(APT_DEBVER)
+ tar -c --exclude=arch-build --no-recursion -f - $(bzr inventory) | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
$(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
(cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)