summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2010-05-24 12:09:45 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2010-05-24 12:09:45 +0200
commit39151234858bb92d2e24ab367ebc14b363b4a48c (patch)
treea4206b720a6602ac0b05c9e194d0cdff148c849a /debian/rules
parenta59397c121813583f5d43f70aa0a779bd0025477 (diff)
use dpkg-buildflags if available for CXXFLAGS
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index f1cb77fbe..827fc2034 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,10 +27,14 @@ endif
# See below
-include build/environment.mak
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+ export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
else
- export CXXFLAGS = -O2 -g -Wall
+ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ export CXXFLAGS = -O0 -g -Wall
+ else
+ export CXXFLAGS = -O2 -g -Wall
+ endif
endif
# Default rule