summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2011-06-08 17:38:55 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2011-06-08 17:38:55 +0200
commitf521559b96d303970f50daa2f9d64c6651861d7e (patch)
treed275763c0ead5b3d33716a4ce028edbae0532420 /debian/rules
parent782486e8219705249d9096c79638bd85b930522d (diff)
do not include libapt-pkg* in apt itself, add missing dh_makeshlibs calls
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 24fb3b9be..a466fbf8f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -201,7 +201,6 @@ apt: build build-doc
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -p$@
dh_installdeb -p$@
dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-inst2.1/usr/lib:$(CURDIR)/debian/libapt-pkg4.10/usr/lib
dh_gencontrol -p$@
@@ -266,6 +265,7 @@ libapt-pkg4.10: build
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
+ dh_makeshlibs -p$@
dh_shlibdeps -p$@
dh_gencontrol -p$@
dh_md5sums -p$@
@@ -283,6 +283,7 @@ libapt-inst1.2: build
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
+ dh_makeshlibs -p$@
dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-pkg4.10/usr/lib
dh_gencontrol -p$@
dh_md5sums -p$@