summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:04:16 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:04:16 +0000
commit2baea622a52a27dffa4dd650895791e1c0a225ae (patch)
tree806fa65602af9328d569710504f32fd8b7be893d /debian/rules
parent1921b71e29ec4d4b6307975ea17e332bf3358fea (diff)
* Pass -ePATH to debuild; clobbering PATH defeats the u...
Author: mdz Date: 2003-12-21 00:22:51 GMT * Pass -ePATH to debuild; clobbering PATH defeats the usual method of using ccache, and apt takes a long time to compile
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index b5c848aa2..ec0150165 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.56 2003/12/21 00:07:35 mdz Exp $
+# $Id: rules,v 1.57 2003/12/21 00:22:51 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -30,7 +30,7 @@ endif
# Default rule
build:
-DEB_BUILD_PROG:=debuild -us -uc
+DEB_BUILD_PROG:=debuild -us -uc -ePATH
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
@@ -104,6 +104,7 @@ build/configure-stamp: configure
build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
+ echo "*************** PATH IS $(PATH) **************"
$(MAKE) binary
touch $@