summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2013-08-15 09:26:00 +0200
committerMichael Vogt <mvo@debian.org>2013-08-15 09:26:00 +0200
commitd7a4635391d9ff36152603ab6faa6eafa206750a (patch)
treee16a562e3e9a195cae286433c5751a1ab9990635 /debian/rules
parent2a49601f69e08f06fb2727d869d420daacdd09d5 (diff)
parent183116d1a64a2610b88fa6b50f2c5199b69d5841 (diff)
Merge branch 'debian/sid' into debian/experimental
Conflicts: apt-pkg/contrib/strutl.cc apt-pkg/deb/dpkgpm.cc configure.ac debian/changelog doc/po/apt-doc.pot po/apt-all.pot po/ar.po po/ast.po po/bg.po po/bs.po po/ca.po po/cs.po po/cy.po po/da.po po/de.po po/dz.po po/el.po po/es.po po/eu.po po/fi.po po/fr.po po/gl.po po/hu.po po/it.po po/ja.po po/km.po po/ko.po po/ku.po po/lt.po po/mr.po po/nb.po po/ne.po po/nl.po po/nn.po po/pl.po po/pt.po po/pt_BR.po po/ro.po po/ru.po po/sk.po po/sl.po po/sv.po po/th.po po/tl.po po/uk.po po/vi.po po/zh_CN.po po/zh_TW.po test/integration/framework test/integration/test-bug-602412-dequote-redirect test/integration/test-ubuntu-bug-346386-apt-get-update-paywall test/interactive-helper/aptwebserver.cc test/interactive-helper/makefile
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules46
1 files changed, 27 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index 5051dab4f..fc44d5a68 100755
--- a/debian/rules
+++ b/debian/rules
@@ -66,7 +66,7 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
# do not fail as we are just experimenting with symbol files for now
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
-build: build/build-stamp
+build-binary: build/build-binary-stamp
build-debiandoc: build/build-debiandoc-stamp
build-manpages: build/build-manpages-stamp
@@ -76,15 +76,15 @@ build-manpages: build/build-manpages-stamp
build/environment.mak: build/configure-stamp
@true
-configure: configure.in
-build/configure-stamp: configure
+configure: configure.ac
+build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
dh_testdir
-mkdir build
cp COPYING debian/copyright
cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
touch $@
-build/build-stamp: build/configure-stamp
+build/build-binary-stamp: build/configure-stamp
# Add here commands to compile the package.
$(MAKE) binary
# compat symlink for the locale split
@@ -110,16 +110,18 @@ build/build-manpages-stamp: build/configure-stamp
clean:
dh_testdir
+ dh_clean
[ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
debian/libapt-pkg-dev.install
+ test ! -L buildlib/config.guess || rm -f buildlib/config.guess
+ test ! -L buildlib/config.sub || rm -f buildlib/config.sub
debian/%.install: debian/%.install.in
sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
-binary-indep: apt-doc libapt-pkg-doc
# Build architecture-independent files here.
libapt-pkg-doc: build-debiandoc
dh_testdir -p$@
@@ -171,9 +173,8 @@ apt-doc: build-debiandoc
# Build architecture-dependent files here.
-binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-manpages
+apt: build-binary build-manpages
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -182,6 +183,8 @@ apt: build build-manpages
# apt install
#
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+ cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
+ chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
# make rosetta happy and remove pot files in po/ (but leave stuff
# in po/domains/* untouched) and cp *.po into each domain dir
@@ -203,7 +206,7 @@ apt: build build-manpages
dh_bugfiles -p$@
dh_lintian -p$@
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
dh_installcron -p$@
dh_installdocs -p$@
dh_installchangelogs -p$@
@@ -217,7 +220,7 @@ apt: build build-manpages
dh_md5sums -p$@
dh_builddeb -p$@
-libapt-pkg-dev: build debian/libapt-pkg-dev.install
+libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -237,7 +240,7 @@ libapt-pkg-dev: build debian/libapt-pkg-dev.install
dh_builddeb -p$@
apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build build-manpages
+apt-utils: build-binary build-manpages
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -253,7 +256,7 @@ apt-utils: build build-manpages
dh_installexamples -p$@
# Install the man pages..
- dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
dh_installchangelogs -p$@
dh_strip -p$@
@@ -266,7 +269,7 @@ apt-utils: build build-manpages
dh_md5sums -p$@
dh_builddeb -p$@
-$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
+$(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -285,7 +288,7 @@ $(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
dh_md5sums -p$@
dh_builddeb -p$@
-$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
+$(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -304,7 +307,7 @@ $(LIBAPT_INST): build debian/$(LIBAPT_INST).install
dh_md5sums -p$@
dh_builddeb -p$@
-apt-transport-https: build libapt-pkg-dev
+apt-transport-https: build-binary libapt-pkg-dev
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -327,13 +330,18 @@ apt-transport-https: build libapt-pkg-dev
dh_md5sums -p$@
dh_builddeb -p$@
+buildlib/config.guess buildlib/config.sub:
+ $(MAKE) "$@"
+
configure:
$(MAKE) configure
-really-clean: clean
- -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
- find -name ChangeLog | xargs rm -f
- rm -f l33ch-stamp
-
+# translate targets to targets required by debian-policy
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
+binary-indep: apt-doc libapt-pkg-doc
binary: binary-indep binary-arch
+build-arch: build-binary
+build-indep: build-manpages build-debiandoc
+build: build-indep build-arch
+
.PHONY: build clean binary-indep binary-arch binary