summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-04-26 20:03:56 +0200
committerJulian Andres Klode <jak@debian.org>2017-05-05 14:50:39 +0200
commit55100ab1e47d24224d2fa1abb3ccce2130469884 (patch)
tree94fba0ca141ca5bafcc030077048860a870b4add /debian/rules
parent82579d3ef511d553d374150b18e6ad6f3cfd872b (diff)
Split apt-daily timer into two
The timer doing downloading runs throughout the day, whereas automatic upgrade and clean actions only happen in the morning. The upgrade service and timer have After= ordering requirements on their non-upgrade counterparts to ensure that upgrading at boot takes place after downloading. LP: #1686470 (cherry picked from commit 496313fb8e83af2ba71f6ce3d729be687c293dfd) (cherry picked from commit a234cfe1466066aa1f404cf01e544f16cb517846)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 7b7df7ad9..621f79b40 100755
--- a/debian/rules
+++ b/debian/rules
@@ -231,8 +231,8 @@ apt: build-binary build-manpages debian/apt.install
dh_installexamples -p$@ $(BLD)/docs/examples/*
dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
dh_installcron -p$@ --name=apt-compat
- dh_systemd_enable -p$@ apt-daily.timer
- dh_systemd_start -p$@ apt-daily.timer
+ dh_systemd_enable -p$@ apt-daily.timer apt-daily-upgrade.timer
+ dh_systemd_start -p$@ apt-daily.timer apt-daily-upgrade.timer
dh_installdocs -p$@
dh_installchangelogs -p$@
dh_installlogrotate -p$@