summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2011-11-23 10:46:56 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2011-11-23 10:46:56 +0100
commit2277979628e2497578f2066ed76b98086c5e9cac (patch)
tree6c3ca12c41ca5a1a965633587b74f59a3d0832a9 /debian/rules
parent82c8f08ec6f2e1ae03ae4598ded13a204f9d272f (diff)
parent879daf177323f6fcb89188255fec07700e2c8bd1 (diff)
merged lp:~mvo/apt/convert-to-multiarch-lib-thanks-colin
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 27 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 30474c06b..6a5c95d22 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,7 @@
export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
# FOR AUTOCONF 2.52 AND NEWER ONLY
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -118,9 +119,31 @@ clean:
[ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
+ rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+ debian/libapt-pkg-dev.install
-binary-indep: apt-doc libapt-pkg-doc
+debian/%.install: debian/%.install.in
+ sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
+
+binary-indep: libapt-common apt-doc libapt-pkg-doc
# Build architecture-independent files here.
+libapt-common: build
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
+
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
libapt-pkg-doc: build-doc
dh_testdir -p$@
dh_testroot -p$@
@@ -217,7 +240,7 @@ apt: build build-doc
dh_md5sums -p$@
dh_builddeb -p$@
-libapt-pkg-dev: build
+libapt-pkg-dev: build debian/libapt-pkg-dev.install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -265,7 +288,7 @@ apt-utils: build
dh_md5sums -p$@
dh_builddeb -p$@
-$(LIBAPT_PKG): build
+$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@
@@ -284,7 +307,7 @@ $(LIBAPT_PKG): build
dh_md5sums -p$@
dh_builddeb -p$@
-$(LIBAPT_INST): build
+$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
dh_testdir -p$@
dh_testroot -p$@
dh_prep -p$@