summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2007-07-23 15:28:32 +0200
committerMichael Vogt <egon@bottom>2007-07-23 15:28:32 +0200
commit4c58917103875358bb30622daf76d58918336968 (patch)
treeb57f9cc8e9c1afd1e50f5e841bda00ca35cf427a /debian/rules
parent6ae549699856b105e840f8345e917e323d9ec591 (diff)
parent394eadc8e13784162fee87c8059bcc214275f4b5 (diff)
* cmdline/apt-get.cc:
- fix in the task-install code regexp (thanks to Adam Conrad and Colin Watson) - support task removal too: apt-get remove taskname^ (thanks to Matt Zimmerman reporting this problem) * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3) * Fix compilation warnings: - apt-pkg/contrib/configuration.cc: wrong argument type; - apt-pkg/deb/dpkgpm.cc: wrong signess; - apt-pkg-acquire-item.cc: wrong signess and orderned initializers; - methods/https.cc: - type conversion; - unused variable; - changed SetupProxy() method to void; * Simplified HttpMethod::Fetch on http.cc removing Tail variable; * Fix pipeline handling on http.cc (closes: #413324) * Fix building to properly support binNMUs. Thanks to Daniel Schepler <schepler@math.unipd.it> by the patch (closes: #359634) * Fix example for Install-{Recommends,Suggests} options on configure-index example file. Thanks to Peter Eisentraut <peter_e@gmx.net> by the patch (closes: #432223) * fixed compile errors with g++ 4.3 (thanks to
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 3ebecfba4..473821f16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')