summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:55:18 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:55:18 +0000
commit0b5c85b5c9edc8cbd9a3962d412810354398b095 (patch)
tree64fa3a52e9d2ab1b34e844213ef0bea864842411 /debian/rules
parent50e1955778d7d2f30ae029b3210b26b7f9f865f6 (diff)
More usr doc fixes
Author: jgg Date: 1999-12-07 07:38:19 GMT More usr doc fixes
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index b3e1d12c1..05dbc4603 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.18 1999/11/23 05:36:52 jgg Exp $
+# $Id: rules,v 1.19 1999/12/07 07:38:19 jgg Exp $
# For the deb builder, you can run 'debian/rules cvs-build', which does all
@@ -53,7 +53,7 @@ build-stamp: configure
# cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
# cd build && make all-hdr
# cd build && make -s
-
+
# Add here commands to compile the package.
make
touch build-stamp
@@ -78,12 +78,13 @@ libapt-pkg-doc: build debian/shlibs.local
dh_installdirs -p$@
#
# libapt-pkg-doc install
-#
+#
+ dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
+ $(BLD)/docs/files* $(BLD)/docs/method*
+
-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
- dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
- $(BLD)/docs/files* $(BLD)/docs/method*
dh_installexamples -p$@
# dh_installmenu -p$@
# dh_installinit -p$@