summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2011-06-28 10:52:13 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2011-06-28 10:52:13 +0100
commitf6c68830b25f73a4b1af144924eb85c442b0f155 (patch)
tree803b49ba04a1ede0657172526f832adfda20a251 /debian/rules
parent0db864630c16afb3ed70370f2ccac3f59475699d (diff)
parentb167bd3959c80d8cc9edfaca647949f99ed122a5 (diff)
merge from the experimental branch and prepare new upload
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules65
1 files changed, 53 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 0544b2b8e..b6f45a38e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -70,9 +70,9 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
# Find the libapt-pkg major version for use in other control files
include buildlib/libversion.mak
-# Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
+# Determine which library package names to use
+LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
# do not fail as we are just experimenting with symbol files for now
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
@@ -97,6 +97,10 @@ build/configure-stamp: configure
build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
$(MAKE) binary
+ # compat symlink for the locale split
+ mkdir -p build/usr/share
+ cd build/usr/share && ln -f -s ../../locale .
+ # done here
touch $@
build/build-doc-stamp: build/configure-stamp
@@ -137,7 +141,7 @@ libapt-pkg-doc: build-doc
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+ dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
@@ -165,7 +169,7 @@ apt-doc: build-doc
# Build architecture-dependent files here.
-binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
apt: build build-doc
dh_testdir -p$@
@@ -205,10 +209,9 @@ apt: build build-doc
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
- dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
@@ -227,7 +230,7 @@ libapt-pkg-dev: build
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+ dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
dh_md5sums -p$@
dh_builddeb -p$@
@@ -253,8 +256,46 @@ apt-utils: build
dh_fixperms -p$@
dh_makeshlibs -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
- dh_gencontrol -p$@ -- -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+$(LIBAPT_PKG): build
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
+
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+$(LIBAPT_INST): build
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
+
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@
@@ -276,7 +317,7 @@ apt-transport-https: build libapt-pkg-dev
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
+ dh_shlibdeps -p$@
dh_gencontrol -p$@
dh_md5sums -p$@
dh_builddeb -p$@