summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:06:32 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:06:32 +0000
commitbad951843ac060cd04a72e77f9d9b563995e391d (patch)
tree31101e096b9cb732500cc1e40c1d0518f62260bb /debian/rules
parentea7f63633bd86d134f543686e4f285a6873c5638 (diff)
Build with -Wall
Author: mdz Date: 2004-04-30 04:37:47 GMT Build with -Wall
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 773b46087..d4d2fb61c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.64 2004/04/30 03:56:33 mdz Exp $
+# $Id: rules,v 1.65 2004/04/30 04:37:47 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -28,9 +28,9 @@ endif
-include build/environment.mak
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- export CXXFLAGS = -O0 -g
+ export CXXFLAGS = -O0 -g -Wall
else
- export CXXFLAGS = -O2 -g
+ export CXXFLAGS = -O2 -g -Wall
endif
# Default rule