summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2015-11-19 22:39:13 +0100
committerDavid Kalnischkies <david@kalnischkies.de>2015-11-19 23:38:49 +0100
commit520624d562e54e8e2c0191fae723e668e3ece6b4 (patch)
tree08e9f1b6fdccea1c08f6efd279d84c9f359149d4 /debian/rules
parent033752214285a40f21f1ceb00a9e0b68ec8fc84f (diff)
do not rerun ./configure causing FTCBFS with newer autotools-dev
If the config.{sub,guess} files we linked in were newer than our configure script we ended up recreating configure and then rerun it without all the configuration options which were (potentially) present for a previous run. We avoid this by changing to the same ruleset as in the debian/rules file which compares the config.* files against a stamp file rather than the configure script itself as its the configuration itself which depends on all scripts, not configure on the config scripts. While at it, we also drop the 'make -s dirs' call as we don't need to do it explicitly here as proper dependencies will take care of it. Thanks: Helmut Grohne for the detailed bugreport. Closes: 804923
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 60966b09f..c8e7cb285 100755
--- a/debian/rules
+++ b/debian/rules
@@ -89,7 +89,7 @@ build/environment.mak: build/configure-stamp
configure: configure.ac
build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
dh_testdir
- -mkdir build
+ mkdir -p build
cp COPYING debian/copyright
cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
touch $@