summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:05:36 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:05:36 +0000
commit5e3c3a3c9c0a942594d467c919db3cd773af1248 (patch)
treec8027d4d9c5d6ef6b7b8f30c957cf218a1f10b18 /debian/rules
parenta7c3025fc527d28871051d17209dfa8ce1f483de (diff)
* Make debian/rules a bit more consistent in a few places.
Author: mdz Date: 2004-02-27 00:51:25 GMT * Make debian/rules a bit more consistent in a few places. Specifically, always use -p$@ rather than an explicit package name, and always specify it first, and use dh_shlibdeps -l uniformly rather than sometimes changing LD_LIBRARY_PATH dircetly
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 0ac423c92..809e26972 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.62 2003/12/24 22:55:30 mdz Exp $
+# $Id: rules,v 1.63 2004/02/27 00:51:25 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -210,9 +210,9 @@ apt: build debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
- dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
+ dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
dh_installdeb -p$@
- dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+ dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@
@@ -268,7 +268,7 @@ apt-utils: build debian/shlibs.local
dh_fixperms -p$@
dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
dh_installdeb -p$@
- LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+ dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
dh_md5sums -p$@
dh_builddeb -p$@