summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2011-11-10 16:56:21 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2011-11-10 16:56:21 +0100
commit7cb543fb742a837c4931513674febaec5e4c1401 (patch)
treeddefe5b9329907818aa6eb3b593f555b29ccb869 /debian/rules
parentf6cb0880a4b5d31e398cceb2e2577b6b82f4fffb (diff)
parent71ecaad29d8066a494f516efc5efd80860653fe2 (diff)
merged from lp:~mvo/apt/mvo (that has all the changes from debian-experimental2) and resolved a bunch of conflicts
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2cfd95b31..71019a746 100755
--- a/debian/rules
+++ b/debian/rules
@@ -103,7 +103,12 @@ build/build-stamp: build/configure-stamp
# compat symlink for the locale split
mkdir -p build/usr/share
cd build/usr/share && ln -f -s ../../locale .
- # done here
+ # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+ $(MAKE) test
+else
+ @echo "Tests DISABLED"
+endif
touch $@
build/build-doc-stamp: build/configure-stamp