summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2016-05-28 15:40:59 +0200
committerDavid Kalnischkies <david@kalnischkies.de>2016-06-27 11:57:12 +0200
commitf74d99c6a78caafdc6e32d8cb135683b7154795c (patch)
tree3056bcf8fa40dd70c65ae073e634aa142ab8e628 /debian/rules
parentdae197476f1831269d13f4e990276ce25c483842 (diff)
eipp: provide the internal planer as an external one
Testing the current implementation can benefit from being able to be feed an EIPP request and produce a fully compliant response. It is also a great test for EIPP in general.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index cd21f30ef..43e979dc8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -189,8 +189,9 @@ apt: build-binary build-manpages debian/apt.install
dh_install -p$@ --sourcedir=$(BLD)
# Remove the bits that are in apt-utils
- rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
+ rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver internal-planer)
cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+ ln -s ../solvers/dump debian/$@/usr/lib/apt/planers/dump
# https has its own package
rm debian/$@/usr/lib/apt/methods/https
@@ -252,6 +253,7 @@ apt-utils: build-binary build-manpages
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
+ cp $(BLD)/bin/apt-internal-planer debian/$@/usr/lib/apt/planers/apt
dh_install -p$@ --sourcedir=$(BLD)
dh_link -p$@