summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2009-08-08 09:53:25 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2009-08-08 09:53:25 +0200
commitdee2822ae83aea4c161036a892cea6622a8e8510 (patch)
treed7ec59b33ee0973ba36123ced62af041c6a15fac /debian
parent2b5c0d21114e200f524c2ff199bf1ce9e0d923fa (diff)
parent9a64707c285290c4e191e04d92c0fab9f6f118f5 (diff)
merge with apt-sid
* backout my fix for the sources.list issue, there is already one in
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily26
-rw-r--r--debian/changelog39
-rw-r--r--debian/control4
3 files changed, 54 insertions, 15 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 4f47ccfab..b6099ee75 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -14,6 +14,9 @@
# Dir::Cache::Archive "archives/";
# - Set package archive directory
#
+# APT::Periodic::Enable "1";
+# - Enable the update/upgrade script (0=disable)
+#
# APT::Periodic::BackupArchiveInterval "0";
# - Backup after n-days if archive contents changed.(0=disable)
#
@@ -46,7 +49,10 @@
#
# APT::Periodic::Download-Upgradeable-Packages "0";
# - Do "apt-get upgrade --download-only" every n-days (0=disable)
-#
+#
+# APT::Periodic::Download-Upgradeable-Packages-Debdelta "1";
+# - Use debdelta-upgrade to download updates if available (0=disable)
+#
# APT::Periodic::Unattended-Upgrade "0";
# - Run the "unattended-upgrade" security upgrade script
# every n-days (0=disabled)
@@ -319,12 +325,18 @@ if ! which apt-config >/dev/null ; then
exit 0
fi
+# check if the user really wants to do something
+AutoAptEnable=1 # default is yes
+eval $(apt-config shell AutoAptEnable APT::Periodic::Enable)
+
+if [ $AutoAptEnable -eq 0 ]; then
+ exit 0
+fi
+
# Set VERBOSE mode from apt-config (or inherit from environment)
+VERBOSE=0
eval $(apt-config shell VERBOSE APT::Periodic::Verbose)
debug_echo "verbose level $VERBOSE"
-if [ -z "$VERBOSE" ]; then
- VERBOSE="0"
-fi
if [ "$VERBOSE" -le 2 ]; then
# quiet for 0,1,2
XSTDOUT=">/dev/null"
@@ -386,6 +398,9 @@ eval $(apt-config shell AutocleanInterval APT::Periodic::AutocleanInterval)
BackupArchiveInterval=0
eval $(apt-config shell BackupArchiveInterval APT::Periodic::BackupArchiveInterval)
+Debdelta=1
+eval $(apt-config shell Debdelta APT::Periodic::Download-Upgradeable-Packages-Debdelta)
+
# check if we actually have to do anything
if [ $UpdateInterval -eq 0 ] &&
[ $DownloadUpgradeableInterval -eq 0 ] &&
@@ -429,6 +444,9 @@ fi
# download all upgradeable packages (if it is requested)
DOWNLOAD_UPGRADEABLE_STAMP=/var/lib/apt/periodic/download-upgradeable-stamp
if [ $UPDATED -eq 1 ] && check_stamp $DOWNLOAD_UPGRADEABLE_STAMP $DownloadUpgradeableInterval; then
+ if [ $Debdelta -eq 1 ]; then
+ debdelta-upgrade >/dev/null 2>&1 || true
+ fi
if eval apt-get $XAPTOPT -y -d dist-upgrade $XSTDERR; then
update_stamp $DOWNLOAD_UPGRADEABLE_STAMP
debug_echo "download upgradable (success)"
diff --git a/debian/changelog b/debian/changelog
index 5822fcae6..403911833 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,4 @@
-apt (0.7.23) unstable; urgency=low
-
- [ Michael Vogt ]
- * cmdline/apt-get.cc:
- - honor APT::Get::Only-Source properly in FindSrc() (thanks to
- Martin Pitt for reporting the problem) (Closes: #535362)
+apt (0.7.22.3) unstable; urgency=low
[ David Kalnischkies ]
* cmdline/apt-get.cc:
@@ -13,11 +8,37 @@ apt (0.7.23) unstable; urgency=low
* apt-pkg/contrib/strutl.cc:
- enable thousand separator according to the current locale
(by Luca Bruno, Closes: #223712)
+
+ -- David Kalnischkies <david@kalnischkies.com> Sat, 08 Aug 2009 09:40:08 +0200
+
+apt (0.7.22.2) unstable; urgency=low
+
+ * debian/apt.cron.daily:
+ - Make sure that VERBOSE is always set (Closes: #539366)
+ - Script can be disabled by APT::Periodic::Enable=0 (Closes: #485476)
+ - Support using debdelta to download packages (Closes: #532079)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 06 Aug 2009 12:17:19 +0200
+
+apt (0.7.22.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * cmdline/apt-get.cc:
+ - honor APT::Get::Only-Source properly in FindSrc() (thanks to
+ Martin Pitt for reporting the problem), also Closes: #535362.
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/mmap.cc:
+ - Fix FTBFS on GNU/kFreeBSD by disabling DynamicMMap::Grow() on
+ non-Linux architectures as it uses mremap (Closes: #539742).
* apt-pkg/sourcelist.cc:
- - only show warning about missing sources.list file if no we have
- no valid sourceentry (Closes: #539731)
+ - Only warn about missing sources.list if there is no sources.list.d
+ and vice versa as only one of them is needed (Closes: #539731).
+ * debian/control:
+ - Add myself to Uploaders.
+ - Increase Standards-Version to 3.8.2.0.
- -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 30 Jul 2009 15:27:30 +0200
+ -- Julian Andres Klode <jak@debian.org> Mon, 03 Aug 2009 12:48:31 +0200
apt (0.7.22) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 84c411509..cb20e2864 100644
--- a/debian/control
+++ b/debian/control
@@ -4,8 +4,8 @@ Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
- Luca Bruno <lethalman88@gmail.com>
-Standards-Version: 3.8.1.0
+ Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
+Standards-Version: 3.8.2.0
Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, docbook-utils (>= 0.6.12), xsltproc, docbook-xsl, xmlto
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/