summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2009-10-24 17:38:06 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2009-10-24 17:38:06 +0200
commit10c9f030e02ccec5c002abc42776f994c124c574 (patch)
treef0c20a5c4bcbf72d330cfa47e3916763be841036 /debian
parent5cbf7810a2d9f8905015d8a7879df095cfb6d6ea (diff)
Bumped libapt version and excluded eglibc from SONAME. (Closes: #448249)
Backported from lp:~mvo/apt/debian-experimental Based on patch by Eugene V. Lyubimkin
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules14
2 files changed, 9 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 80369e8e7..e7a7e1c49 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -35,6 +35,8 @@ apt (0.7.25) UNRELEASED; urgency=low
[ Eugene V. Lyubimkin ]
* apt-pkg/contib/strutl.h
- Avoid extra inner copy in APT_MKSTRCMP and APT_MKSTRCMP2.
+ * build infrastructure:
+ - Bumped libapt version, excluded eglibc from SONAME. (Closes: #448249)
[ Julian Andres Klode ]
* doc/apt.conf.5.xml:
diff --git a/debian/rules b/debian/rules
index d19531dfc..d1b77e172 100755
--- a/debian/rules
+++ b/debian/rules
@@ -79,21 +79,21 @@ export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f
export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
# Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
debian/shlibs.local: apt-pkg/makefile
# We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
# the right overrides..
rm -rf $@ $@.apt $@.apt-utils
- echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
- echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
- echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+ echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
- echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
- echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+ echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
build: build/build-stamp
build-doc: build/build-doc-stamp